Upgrading to IE 11?

If you are on K2 smartforms 1.0.7 or earlier, you need to upgrade to K2 smartforms 4.6.9 or later. We recommend the upgrade be done sooner rather than later!

If you have smartforms 4.6.9 or later and you are getting "Your browser's compatibility mode is not supported", disable Enterprise mode for IE 11 and/or removing the smartforms sites from the Enterprise Mode Site List.

For more information please contact us.

Featured Posts
Recent Posts
Archive
Search By Tags
IT Solutions for your business